Updated Debian WordPress 2.0 refuses to run?

Did you update WordPress with Debian’s 2.0-1 package and now you only get the message

Your PHP installation appears to be missing the MySQL which is required for WordPress.

when turning your browser to your blog?

Well, this seems to be an old bug that somehow did not make it into the Debian package. Check out Ticket #1496 at trac.wordpress.org, where reason and fix are described.

Actually, the fix is quite simple: Just add an

if ( !
dl('mysql.so') )

before line 50 (the one that dies with the error message) in wp-settings.php and your blog is running again.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.